Allegro使用簡介

admin @ 2014-03-26 , reply:0

一.零件建立
在Allegro 中, Symbol 有五種, 它們分別是Package Symbol 、Mechanical Symbol、Format Symbol、Shape Symbol、Flash Symbol。每種Symbol 均有一個Symbol Drawing File(符號繪圖文件), 後綴名均為*.dra。此繪圖文件只供編輯用, 不能給Allegro 資料庫調用。Allegro 能調用的Symbol 如下:

  1. Package Symbol
    一般元件的封裝符號, 後綴名為*.psm。PCB 中所有元件像電阻、電容、電感、IC 等的封裝類型即為Package Symbol。
  2. Mechanical Symbol
    由板外框及螺絲孔所組成的機構符號, 後綴名為*.bsm。有時我們設計PCB 的外框及螺絲孔位置都是一樣的, 比如顯卡, 電腦主板, 每次設計PCB時要畫一次板外框及確定螺絲孔位置, 顯得較麻煩。這時我們可以將PCB的外框及螺絲孔建成一個Mechanical Symbol, 在設計PCB 時, 將此Mechanical Symbol 調出即可。
  3. Format Symbol
    由圖框和說明所組成的元件符號, 後綴名為*.osm。比較少用。
  4. Shape Symbol
    供建立特殊形狀的焊盤用, 後綴為*.ssm。像顯卡上金手指封裝的焊盤即為一個不規則形狀的焊盤, 在建立此焊盤時要先將不規則形狀焊盤的形狀建成一個Shape Symbol, 然後在建立焊盤中調用此Shape Symbol。
  5. Flash Symbol
    焊盤連接銅皮導通符號, 後綴名為*.fsm。在PCB 設計中, 焊盤與其周圍的銅皮相連, 可以全包含, 也可以採用梅花辨的形式連接, 我們可以將此梅花辨建成一個Flash Symbol, 在建立焊盤時調用此Flash Symbol。

其中應用最多的就是Package symbol即是有電氣特性的零件,而PAD是Package symbol構成的基礎.

一)建立PAD
    啟動Padstack Designer來製作一個PAD,PAD按類型分分為:

  1.  Through,貫穿的;
  2.  Blind/Buried,盲孔/埋孔;
  3.  Single,單面的.

按電鍍分:

  1. Plated,電鍍的;
  2. Non-Plated,非電鍍的.

a.在Parameters選項卡中, Size值為鑽孔大小;Drill symbol中Figure為鑽孔標記形狀,Charater為鑽孔標記符號,Width為鑽孔標記得寬度大小,Height為鑽孔標記得高度大小;
b.Layers選項卡中,Begin Layer為起始層,Default Internal為默認內層,End Layer為結束層,SolderMask_Top為頂層阻焊, ,SolderMask_Bottom為底層阻焊PasteMask_Top為頂層助焊, PasteMask_Bottom為底層助焊;Regular Pad為正常焊盤大小值,Thermal Relief為熱焊盤大小值,Anti Pad為隔離大小值.

二)建立Symbol

  1. 啟動Allegro,新建一個Package Symbol,在Drawing Type中選Package Symbol,在Drawing Name中輸入文件名,OK.
  2. 計算好坐標,執行Layout→PIN,在Option面板中的Padstack中找到或輸入你的PAD,Qty代表將要放置的數量,Spacing代表各個Pin之間的間距,Order則是方向Right為從左到右,Left為從右到左,Down為從上到下,Up為從下到上;Rotation是Pin要旋轉的角度,Pin#為當前的Pin腳編號,Text block為文字型大小數;
  3. 放好Pin以後再畫零件的外框Add→Line,Option面板中的Active Class and Subclass分別為Package Geometry和Silkscreen_Top,Line lock為畫出的線的類型:Line直線;Arc弧線;後面的是畫出的角度;Line width為線寬.
  4. 再畫出零件實體大小Add→Shape→Solid Fill, Option面板中的Active Class and Subclass分別為Package Geometry和Place_Bound_Top,按照零件大小畫出一個封閉的框,再填充之Shape→Fill.
  5. 生成零件Create Symbol,保存之!!!

三) 編寫Device
    若你從orCad中直接生成PCB的話就無需編寫這個文件,這個文件主要是用來描述零件的一些屬性,比如PIN的個數,封裝類型,定義功能等等!以下是一個實例,可以參考進行編寫:
74F00.txt
(DEVICE file: F00 - used for device: 'F00')
PACKAGE SOP14 ⎫ 對應封裝名,應與symbol相一致
CLASS IC ⎫ 指定封裝形式
PINCOUNT 14 ⎫ PIN的個數
PINORDER F00 A B Y ⎫ 定?Pin Name
PINUSE F00 IN IN OUT ⎫ 定?Pin 之形式
PINSWAP F00 A B ⎫ 定?可Swap 之Pin
FUNCTION G1 F00 1 2 3 ⎫ 定?可Swap 之功能(Gate) Pin
FUNCTION G2 F00 4 5 6 ⎫ 定?可Swap 之功能(Gate) Pin
FUNCTION G3 F00 9 10 8 ⎫ 定?可Swap 之功能(Gate) Pin
FUNCTION G4 F00 12 13 11 ⎫ 定?可Swap 之功能(Gate) Pin
POWER VCC; 14 ⎫ 定??源Pin 及名?
GROUND GND; 7 ⎫ 定?Ground Pin 及名?

二、導入網表
Ⅰ. 網錶轉化
在調入前,應該將要增加的定位孔和定位游標以及安裝孔加到網表中,定位孔用M*表示,定位游標用I*表示
Ⅱ . 進入Allegro,File/Import/Logic調入網表,若顯示"0 errs,0 warnings"則表示沒有錯誤,可以進行下一步,否則,應用File/Viewlog 查看原因,根據提示要求電路設計者修改原理圖或自己在元器件庫中加新器件.

四. 設置
Ⅰ設置繪圖尺寸,畫板框,標註尺寸,添加定位孔,給板框導角
1. 設置繪圖尺寸:Setup→Drawing Size
2. 畫板框:Class: BOARD GEOMETRY Subclass: OUTLINE
Add→Line 用 "X 橫坐標 縱坐標" 的形式來定位畫線
3.畫Route Keepin:Setup→Areas→Route Keepin
用 "X 橫坐標 縱坐標" 的形式來定位畫線
4.導角: 導圓角 Edit→ Fillet 目前工藝要求是圓角 或 在右上角空白部分點擊滑鼠右鍵→選Design Prep→選Draft Fillet小圖標
導斜角Edit→Chamfer 或 在右上角空白部分惦記點擊滑鼠右鍵→選Design Prep→選Draft Fillet 小圖標
最好在畫板框時就將角倒好,用絕對坐標控制畫板框,ROUTE KEEPIN,ANTIETCH,ANTIETCH可以只畫一層,然後用EDIT/COPY,而後 EDIT/CHANGE編輯至所需層即可.
5. 標註尺寸: 在右上角空白部分惦記點擊滑鼠右鍵→選Drafting
Class: BOARD GEOMETRY Subclass: Dimension
圓導角要標註導角半徑.在右上角點擊右鍵→選Drafting,會出現有關標註的各種小圖標
Manufacture→Dimension/Draft→Parameters...→進入Dimension Text設置
在標註尺寸時,為了選取兩個點,應該將Find中有關項關閉,否則測量的 會是選取的線段
注:不能形成封閉尺寸標註
6.加游標定位孔:Place→By Symbol→Package,如果兩面都有貼裝器件,則應在正反兩面都加游標定位孔,在在庫中名字為ID-BOARD.如果是反面則要鏡像.
Edit→Mirror
定位游標中心距板邊要大於 8mm.
7. 添加安裝孔:Place→By Symbol→Package,工藝要求安裝孔為3mm.在庫中名字為HOLE125
8.設置安裝孔屬性:Tools→PADSTACK→Modify
若安裝孔為橢圓形狀,因為在印製板設計時只有焊盤可以設成橢圓,而鑽孔只可能設成圓形,需要另外加標註將其擴成橢圓,應在尺寸標註時標出其長與寬. 應設成外徑和Drill同大,且Drill 不金屬化
9. 固定安裝孔:Edit→Property→選擇目標→選擇屬性Fixed→Apply→OK
Ⅱ 設置層數
Setup→Cross-Section...
Ⅲ 設置顯示顏色
Display→Colour/Visibility
可以把當前的顯示存成文件:View→Image Save,以後可以通過View→Image Restore調入,生成的文件以view為後綴,且此文件應該和PCB文件存在同一目錄下。
Ⅳ 設置繪圖參數
Setup→Drawing Options
Display中的Thermal Pads和Filled Pads and Cline Endcaps應該打開
Ⅴ 設置布線規則
Setup→Constraints... Set Standard Values...設置Line Width ,Default Via
Spacing Rules Set→Set Values...設置Pin to Pin ,Line to Pin,Line to Line等值

五. 調入元件
1 給元件賦屬性:Edit→Properties→進入Find設置→Find By Name選擇Comp(or Pin)→More→選擇All→Apply→選擇Placement-tag自動放置屬性→Apply→OK
2 畫元件放置區:Setup→Areas→Package Keepin→畫一方框作為元件放入區→右鍵,Done→Place→Autoplace→Top Grids→50,OK→50,OK→點擊所畫方框
3 自動放置器件:Place→Autoplace→Design
4 移動元件的設置:在移動狀態下,可以設置Options類中的Point
Sym Origin,:以器件原點
Body Center:以器件中心
User Pick:以選取點
Sym Pin#:以元件某一管腳。

六. 元件布局
布局時,應根據原理圖,將同一模塊的器件放到一起,而後再根據連接長度最短的原則將同一模塊內的器件擺至最短且最美觀為止.再根據鼠線和整塊板子的信號流動方向進行布局.
在Allegro中布局之時,BGA須以25倍(針對Pin間距為50mil而言)的柵格布局。
注意: 1.BGA周圍5mm內無其他器件
2.壓接件周圍5mm內無其他器件
3.有極性插裝件X,Y方向盡量一致
4.板邊5mm為禁布區

七. 電源地層分割
1.畫ROUTE KEEPIN:
Setup→Area→Route Keepin→在右邊Options下,設置成Route Keepin,All→畫框
應注意此步不能缺少,否則後面無法賦電源地網路.
2.畫分割線
將同一層中要分割的不同網路用不同顏色高亮
Add →Line→在右邊Options下,設置成Antietch,以及要分割的層→畫線將不同網路分割開
3. 給電源地層的網路賦屬性
例如:將VCC,VDD,GND分配到電源地層.
Edit→Properties→從右側Find中選Net,More→將VCC,VDD,GND選中→ Apply→賦予No Rats,Route to Shape屬性→結束Edit Property編輯狀態.
4. 將網路分配到相應區域:
Edit→Split Plane→Set Parameter(一切都OK)
Edit→Split Plane→Creat

十. 打電源地
進入SPECCTRA
1.選擇打電源地過孔類型,Select→Vias For Routing→By list...→選擇所需類型,Apply
2.Autoroute→ Setup... →Set Wire Grid...→X Grid和Y Grid 都設為0.1→Apply→OK
Autoroute→Setup... →Set Wire Grid...→X Grid和Y Grid 都設為0.1
3.Autoroute→Pre Route...→Fanout...→只選Power nets→插入→OK

十一. 走線
1. 改變當前預設走線過孔,Setup→Constraints→Physical Rule Set→Current Via List中的排在第一位的過孔類型就是當前預設的過孔類型,將其刪除,則原來排在第二未的過孔類型就變成了預設.只需再加上刪除的過孔類型,則其將排在最後.
2. 在Allegro中,Route→Connect則會在右側出現走線的各種條件設置,包括線寬和過孔 類型.在最下面有兩個選項,Snap to Connect Point,Replace Etch,前者一般不選,否則有可能走不出想要走出的形狀,後者應該選中.
3. 有時走完線后發現報告衝突,說Line to SMD違反contraints,而此line 和SMD屬於同一個網路,此時應該將 Setup→Contraints...→Spacing Rule Set→Set Value...→Same Net Drc設置成off
注:1.板邊3mm不準走線
4 在Allegro中拷貝同時拷貝多條相同走線的方法
要想同時拷貝多條線,必須要保證元器件之間距離嚴格匹配,不能存在一點偏 差,因為在Allegro中可以存在孤島式的走線,所以如果不匹配,仍可以把線拷貝上,但會認為是並未連接上,只把其作為單獨一條線.
用information獲得兩組相同布局中相同位置管腳的坐標,例:已布線部分中管腳 1坐標為(x1,y1),未布線部分中相同管腳坐標為(x2,y2)
選擇Copy狀態→點擊滑鼠右鍵→選Temp Group→用滑鼠選中所有將要拷貝的線→點擊滑鼠右鍵→選Compelete→鍵入x x1,y1設置拷貝原點→鍵入x x2,y2將線拷貝至所需位置→點擊滑鼠右鍵→選Done

十二. 調整衝突

十四. 檢查修改
同時,有一部分錯誤是可以忽略的,要仔細加以區分,最好只顯示布線層的錯誤 (一) Tools→Reports...→選取Summary Drawing Report→Run→查看Connection Statistics中內容,最終目標:Already Connected與Connections相等,Missing Connections等於0,Dangling Connections等於0,Connections 等於100%.
1. 若Already Connected小於Connections,說明存在半截線,此時應將所有賦了No Rats屬性的網路都取消該屬性(Edit→Properties...)→Display→Colout/Visibility→在Global Visibility中選取All Invisible→設置Group/Display中的Ratnest顏色為顯眼的顏色→
觀察 圖中飛線的位置,發現后通過右側的Visibility打開相應層進行修改.
2. 若Dangling 不等於0,說明有的走線多出一截,形成了小天線,則應看Log File 文件,File→File Viewer...→dangling_lines.log→記下坐標→用X 橫坐標 縱坐標定位進行 修改

十五. 調整絲印
設置絲印標準:
Setup→Text Sizes...可以設置四種標準

Blk Width Height Line Space Photo Width Char Space
1 48 60 20 0 0
2 64 80 30 0 0
3 120 150 40 0 0
4 160 200 60 0 20

選Block1 的字體,如果空間足夠大,則選Block2的字體,左至右自下至上的原則.
絲印一定不能上焊盤.

十六. 寫標註文字,做光繪
1.光繪文件命名方式詳見PCB設計文件命名表

ALLEGRO 鏡象 圖紙標註
元件面光繪 art1.art  no (boardname:) artwork top
焊接面光繪 art(n).art yes (boardname:) artwork bottom
內層布線光繪 art(m).art  no (boardname:) artwork layer(m)
地層光繪 ground(m).art  no  (boardname:) ground plane(m)
電源層光繪 power(m).art  no (boardname:) power plane(m)
元件面絲印 silkt.art  no  (boardname:) silkscreen top
焊接面絲印 silkb.art yes (boardname:) silkscreen bottom
元件面阻焊 soldt.art  no (boardname:) soldmask top
焊接面阻焊 soldb.art yes (boardname:) soldmask bottom
元件面鋼網 pastt.art  no (boardname:) pastemask top
焊接面鋼網 pastb.art yes (boardname:) pastemask bottom
元件面裝配 adt.art  no (boardname:) silkscreen top
焊接面裝配 adb.art yes (boardname:) silkscreen bottom
鑽孔圖光繪 drill.art  no (boardname:) drill chart
數控鑽孔文件ncdrill.tap    

註:以上文件名中(n)表示板的總層數,(m)表示內部某層,如6層板的第二層為layer2,而不是Layer1,(n)和(m)均為兩位數.(boardname:)用實際板名替換

2. 可以用File→Import→Sub Drawing...調用以前設計中的標註來進行修改,後綴是clp.

3.光繪文件生成步驟:
Manufacture→NC→Drill Paremeters...→只有Reapeat codes要選中.
Manufacture→NC→Drill Legend
Manufacture→NC→Drill Tape...
Manufacture→Artwork→Parameter→ Suppress項中Leading Zeroes,Equal Coordinates要選中.
Manufacture→Artwork→Film...
film中應包括的內容:
Art(m).art VIA CLASS Art(n)
PIN Art(n)
ETCH Art(n) BOARD GEOMETRY OUTLINE
Ground or power(m).art ANTIETCH Pgp(m)
VIA CLASS Pgp(m)
PIN Pgp(m)
ETCH Pgp(m)
BOARD GEOMETRY OUTLINE
SILKT REF DES SILKSCREEN_TOP
PACKAGE GEOMETRYSILKSCREEN_TOP
BOARD GEOMETRY OUTLINE
BOARD GEOMETRY SILKSCREEN_TOP
SILKB REF DES SILKSCREEN_BOTTOM
PACKAGE GEOMETRYSILKSCREEN_BOTTOM
BOARD GEOMETRY OUTLINE
BOARD GEOMETRY SILKSCREEN_BOTTOM
SOLDT VIA CLASSSOLDERMASK_TOP
PIN SOLDERMASK_TOP
PACKAGE GEOMETRYSOLDERMASK_TOP
BOARD GEOMETRY OUTLINE
BOARD GEOMETRY SOLDERMASK_TOP
SOLDB VIA CLASSSOLDERMASK_BOTTOM
PIN SOLDERMASK_BOTTOM PACKAGE GEOMETRY SOLDERMASK_BOTTOM
BOARD GEOMETRY OUTLINE
BOARD GEOMETRY SOLDERMASK_BOTTOM
DRILL MANUFACTURINGNCDRILL_LEGEND
MANUFACTURINGNCDRILL_FIGURE
BOARD GEOMETRY OUTLINE
BOARD GEOMETRY DIMENSION
ADT REF DES SILKSCREEN_TOP
PIN TOP
PACKAGE GEOMETRYSILKSCREEN_TOP
BOARD GEOMETRY OUTLINE
BOARD GEOMETRY SILKSCREEN_TOP
ADB REF DES SILKSCREEN_BOTTOM
PIN BOTTOM
PACKAGE GEOMETRYSILKSCREEN_BOTTOM
BOARD GEOMETRY OUTLINE
BOARD GEOMETRY SILKSCREEN_BOTTOM1
PASTT PIN PASTEMASK_TOP
BOARD GEOMETRY OUTLINE
BOARD GEOMETRY PASTEMASK_TOP
PASTB PIN PASTEMASK_BOTTOM
BOARD GEOMETRY OUTLINE
BOARD GEOMETRY PASTEMASK_BOTTOM
在命令行執行Artwork -s *.brd命令,效果同Manufacture→Artwork→Generate...,

十七. 光繪問題
生成光繪時常見問題的解決方法

  1. 在光繪后,某一雙列插針的地層全是花盤,實際只應一個管腳接地
    原因:該器件焊盤設置錯誤,將焊盤設置中的ANTI-PAD選項中FLASH填了內 容,實際上只有THERMAL-RELIEF中的FLASH需要填寫,其餘的FLASH 選項都應為空.所以在最後檢查時應該將所有帶通孔的焊盤都檢查一遍.
  2. 光繪時,生成的光繪文件只有5個位元組,所有的文件都無法生成.
    原因:因為存在未使用的焊盤,在生成APERTURES時,存在不可識別的FLASH NAME,如AB00,而非數值,
    解決方法:將未用的PADSTACK清除(PURGE), TOOLS/ PADSTACK/ MODIFY/ PURGE/ALL.
  3. 在某一信號層添加銅皮的方法:
    換到要敷銅的層.
    Add/Shapes/Solid Fill 是敷實心銅皮,而Cross Hatch Fill則是畫柵格式焊盤/ 畫出敷銅的邊框,則菜單將會變成SHAPE編輯菜單
    Edit/Change Net(name)/選擇要賦予的網路,OK/Void/Auto表示自動產生熱焊盤,並且避開過孔,Shape表示在敷銅區域中畫一區域,在此區域中不敷銅,circle表示畫一圓形區域,在此區域中不敷銅,element表示將選中的element,只對過孔類元素有效對於shape,circle都不會自動產生熱焊盤和避開過孔/Shape/Fill即可.
    編輯敷銅
  4. 在用ALLEGRO自作PCB時出現過過孔上焊盤而不報錯的現象,這與我們各位的參數設置有關,為避免此類錯誤的發生,建議更改設置:
    Setup/constraints/physical rule set/set values/pad_pad direct connect:"all allowed-->not allowed"
    Setup/constraints/physical rule set/DRC mode /pad_pad direct connect:"never-->always"



[admin via 研發互助社區 ] Allegro使用簡介已經有7251次圍觀

http://cocdig.com/docs/show-post-44165.html