PCB設計軟體坐標數據導出方法

admin @ 2014-03-26 , reply:0

概述
   現代電子生產企業的設計部門幾乎全部採用PCB軟體進行電路設計,生產製造部門也大量使用貼片機、插件機等自動化設備進行生產,如何在這兩者之間建立起有效的聯繫,進而提高生……

    現代電子生產企業的設計部門幾乎全部採用PCB軟體進行電路設計,生產製造部門也大量使用貼片機、插件機等自動化設備進行生產,如何在這兩者之間建立起有效的聯繫,進而提高生產效率、降低生產成本是工藝技術人員研究的目標。事實上,SMT生產線中加工設備編程所需的大多數特徵數據完全可以從PCB設計文件中獲取,例如元件在PCB 上的 位置坐標、PCB的整體描述數據等等。我們可以直接從PCB設計文件中導出相應的CAD 坐標數據,並與設計部門提供的BOM(Bill of Material,物料表)文件合併後轉換為能驅動貼片設備運行的貼片程序,然後通過磁碟、U 盤、網路或 RS-232C 介面等傳送到加工設備的控制計算機中直接驅動數控加工設備。這樣不僅節省了數據準備及編程時間,也提高了數據精度、杜絕了人工處理數據時所出現的差錯和數據不完整性。
    目前市場上 PCB設計軟體眾多,如 Altium 公司的 Protel 和 P-cad、Mentor 公司的 Powerpcb/Pads 和 Mentor Expedition、Cadence 公司的 Allegro 和 Orcad、日本 Zuken 公司的 Cadstar 和 CR-5000 等等,尤其是Protel、Pads 和 Allegro 三種 PCB 設計軟體,幾乎佔據中國 PCB 設計軟體市場 80%以上的份額,換句話說,如果掌握了這三種 PCB 設計軟體的坐標數據導出方法,基本上就可以應對大多數新產品的挑戰了,這對於承接大量外協產品的 EMS 工廠尤其重要。但問題是現在有很多工藝技術人員,特別是剛剛從事 SMT 行業的,並不掌握 PCB 設計軟體坐標數據的導出方法,也就無法將 CAD 坐標數據轉換為貼片程序,依然停留在利用貼片設備攝像頭一個個在電路板上找元件坐標數據的原始貼片程序編輯方法上,這嚴重製約了生產效率和質量的提升。本文將詳細介紹所有常見 PCB 設計軟體坐標數據的導出方法及步驟,以給從事相關工作的工藝技術人員提供參考。筆者總結的坐標數據導出方法 有三種:
1)利用 PCB 設計軟體自身功能導出;
2)利用專門 CAM 軟體導出;
3)將一種不常見的 PCB 文件格式轉換為另外一種常見格式 PCB 文件后再導出。
    具體採用何種方法要根據具體情況而定,不能一概而論,本文將逐一介紹這幾種方法。

2    利用PCB設計軟體自身功能導出坐標數據
這是最常見的坐標數據導出方法,大多數工廠都採用這種方法獲取元件坐標數據,步驟大致可以分為三步:
1)單位切換;
2)設置坐標原點;
3)坐標導出。
下面將分別介紹一些常見 PCB 設計軟體坐標數據的導出方法。
2.1   PADS
PADS 軟體是 Mentor 公司出品的面向中低端用戶的一款優秀電路板設計軟體,目前最新版本號是 2007,PADS 軟體導出坐標文件步驟如下:
1)用 PADS 打開 PCB 文件。
2)切換公制單位。因為貼片機的單位是 mm,有些圖形是以 mil 作單位,所以要切換成公制單位。具體操作過程如下:選擇菜單“Setup→Preference”,在 Global 選項卡中 Design Unit 欄中選擇 Metric,即切換為公制單位。
3)設定坐標原點。選擇菜單“Setup→Set Origin”,用滑鼠在 PCB 上選定恰當的位置並確定為新的坐標原點,一般選擇 PCB 左下角。
4)輸出坐標數據。選擇菜單“File→CAM”,彈出如圖 1 所示界面,在 Side 欄中選擇 PCB 頂層或底層(Top or Bottom),Parts 欄中選擇 SMT,Output 中選擇輸出貼片機格式, 這裡選擇 Dynapert Promann,然後點擊“Run”按鈕,在彈出的提示文件存檔路徑的對話框 中點擊確認鍵,坐標數據導出。
 
圖 1   PADS 坐標數據輸出

2.2   Protel
    Protel 軟體是最早進入中國板級設計市場的 PCB 設計軟體,在中國擁有眾多的用戶,影響力巨大,目前最新版本號是 AD6.9,本文以 Protel 99 軟體為例介紹坐標文件導出方法, 步驟如下:
1)用 Protel99 軟體打開 PCB 文件。
2)設定原點。選擇菜單“Edit →Origin → Set”,設定坐標原點。
3)導出坐標數據。選擇菜單“File→Cam Manager…”,出現輸出數據嚮導界面,按“Next”,
選擇輸出數據類型為 Pick Place(如圖 2),再依次按“Next”繼續,注意文件格式選擇 Text(文本)、單位選擇 Metric(公制)。然後選擇菜單“Tools→ Preference…”,在彈出的 CAM Options 對話框中設定輸出坐標文件所在的目錄,選擇菜單“Tools →Generate CAM Files” 在指定路徑下生成坐標文件。
 
圖 2   Protel 輸出數據類型選擇

2.3 Allegro
Allegro 軟體是 Cadence 公司出品的面向中高端企業用戶的 PCB 設計軟體,主要針對高速、高密度電路板設計,尤其在通訊等領域被廣泛應用,目前最新版本號是 16.0。Allegro 軟體導出坐標數據步驟:
1) 用 Allegro 軟體打開 PCB 設計文件。
2) 設定原點和切換公制單位。選擇菜單“Setup → Drawing Size…”,彈出如圖 3 所示對話框,用戶單位選擇 millimeter,MOVE ORIGIN 欄中輸入新原點位置相對於當前原點的坐標數據,然後按“OK”確定。
 
圖 3   Allegro 單位切換和原點設定
3) 坐標文件導出。選擇菜單“File → Export → Placement…”,彈出如圖4 所示對話框,
注意 Placement Origin 選擇 Body Center,按“Export”按鈕輸出坐標數據。 
 
圖 4 Allegro 坐標輸出對話框

2.4 Orcad
    Orcad 是 Cadence 公司推出的面向中低端市場的一款 PCB 設計軟體,目前新版本的Cadence Allegro 軟體中都集成了 Orcad 軟體。Orcad 軟體導出坐標數據步驟:
1) 用 Orcad 軟體打開 PCB 設計文件。
2) 設定原點。選擇菜單“Tool → Dimension → Move Datum”,用滑鼠在 PCB 上選定恰當的位置為新的坐標原點。
3) 坐標數據導出。選擇菜單“Auto → Create Reports…”,彈出如圖5 所示對話框,選定輸出項目,例如 Comp ALL(Comps),按確定按鈕后在 PCB 所在目錄下生成坐標數據文件。
 
圖 5   Allegro 坐標輸出對話框

2.5 Mentor Expedition
    Mentor Expedition 是 Mentor 公司出品的另外一款 PCB設計軟體,與 Allegro 軟體市場 定位一樣,也是面向中高端企業用戶的,Mentor Expedition 軟體導出坐標數據步驟如下:
1)用 Mentor Expedition 軟體打開 PCB 設計文件。
2)單位切換。選擇菜單“Setup → Setup Parameter…”,在彈出的對話框中選擇單位為Millimeters。
3)設定原點。選擇菜單“Edit → Place → origin…”,在彈出的對話框中 Type 類型選擇為Board(如圖 6),Location 欄中輸入新原點位置相對於當前原點的坐標數據。
 
圖 6   Expedition 軟體設置原點對話框
4) 坐標數據導出。選擇菜單“File → Export → General Interface…”,在彈出對話框中選擇“Generic AIS”(如圖 7),按確定鍵后在當前 PCB 文件中 PCBOUTPUT 目錄下生成坐標文件。
  
圖 7   Expedition 軟體坐標文件導出

2.6   Cadstar
    Cadstar 是日本 Zuken 公司推出的面向中低端用戶的電路板設計軟體,其市場定位與 PADS 軟體相似,但市場佔有率遠不及 PADS,主要在一些日本及台灣公司使用,目前最新版本號 9.0,其坐標數據導出步驟如下:
1)用 Cadstar 軟體打開 PCB 設計文件。
2)單位切換。選擇菜單“Settings → Units…”,在彈出的對話框中選擇單位為 Millimeters。
3)坐標原點設定。選擇菜單“Settings → Design Origin…”,彈出的如圖 8 所示對話框, 選中“Origin Position Relative to Current Origin”複選框,X 和 Y 坐標欄中輸入新原點位置相對於當前原點的坐標數據。
 
圖 8   Cadstar 軟體設置原點對話框
4)輸出坐標數據。選擇菜單“Tools → Report Generate → Manager Reports…”,彈出如圖 9 所示對話框,點擊 Open 按鈕,選擇產生文件類型為 comp_SMD.rgf,再按 Run 按鈕生成坐標文件。
 
圖 9   Cadstar 軟體坐標導出對話框



[admin via 研發互助社區 ] PCB設計軟體坐標數據導出方法已經有5279次圍觀

http://cocdig.com/docs/show-post-44127.html