Modelsim簡明使用指南

admin @ 2014-03-26 , reply:0

1 前言
    作為一種簡單易用,功能強大的邏輯模擬工具,Modelsim具有廣泛的應用。這裡對ModelSim作一個入門性的簡單介紹。首先介紹ModelSim的代碼模擬,然後介紹門級模擬和時序驗證。

2 代碼模擬
    在完成一個設計的代碼編寫工作之後,可以直接對代碼進行模擬,檢測源代碼是否符合功能要求。這時,模擬的對象為HDL代碼,比較直觀,速度比較快,可以進行與軟體相類似的多種手段的調試(如單步執行等)。在設計的最初階段發現問題,可以節省大量的精力。

2.1 代碼模擬需要的文件

  1. 設計HDL源代碼:可以使VHDL語言或Verilog語言。
  2. 測試激勵代碼:根據設計要求輸入/輸出的激勵程序,由於不需要進行綜合,書寫具有很大的靈活性。
  3. 模擬模型/庫:根據設計內調用的器件供應商提供的模塊而定,如:FIFO(Altera常用的FIFO有:lpm_fifo /lpm_fifo_dc等)、DPRAM等。

2.2 代碼模擬步驟
1.建立工程:在ModelSim中建立Project。如圖2.1所示,點擊File→New→Project,得到Creata Project的彈出窗口,如圖2.2所示。在Project Name欄中填寫你的項目名字,建議和你的頂層文件名字一致。Project Location是你的工作目錄,你可通過Brose按鈕來選擇或改變。Ddfault Library Name可以採用工具默認的work。
 
圖2.1
 
圖2.2
2.給工程加入文件:ModelSim會自動彈出Add Items to the project窗口,如圖2.3所示。選擇Add Exsiting File后,根據相應提示將文件加到該Project中。
 
圖2.3
3.編譯:編譯(包括源代碼和庫文件的編譯)。編譯可點擊Comlile→Comlile All來完成。
4.裝載文件:如圖2.4,點擊Simulate→Simulate…后,如圖2.5所示,選定頂層文件(激勵文件),ADD加入,然後點擊LOAD,裝載。
 
圖2.4
 
圖2.5
5.開始模擬:通過菜單:View →Structure,View → Signals,View → Wave打開Structure,Signals,Wave三個窗口。在Structure窗口內選定你所要觀察的信號所在的模塊,然後在Signals窗口選定信號,通過滑鼠左鍵拖放到Wave窗口,如圖2.6。然後在Wave窗口,點擊run all,運行,在波形窗口就可以看到信號的模擬波形。如圖2.7.
 
圖2.6
 
圖2.7
6.波形信號的保存:有時,在波形窗口內拖放了較多的信號,可以保存起來以後調入。在wave窗口,File → Save format,保存成*.do文件。以後需要調入時,在modelsim主窗口命令行內執行:do *.do即可。



[admin via 研發互助社區 ] Modelsim簡明使用指南已經有1185次圍觀

http://cocdig.com/docs/show-post-43051.html