PROTEL DXP創建原理圖器件

admin @ 2014-03-26 , reply:0

    介紹了使用PROTEL DXP 的庫編輯器創建原理圖器件和PCB 封裝。這個指南假設你能理解如何在原理圖及PCB 環境中工作並且具有擺放及編輯器件的能力。你可以在AltiumExamples utorials 路徑中找到指南中的例子中使用到的器件及庫。
    在指南中,我們將要介紹到以下的主題:

  • 創建一個新的庫
  • 創建含有一個部件及多個部件的原理圖元件
  • 用原理圖庫編輯器報告檢查器件

創建原理圖元件
    PROTEL DXP 中提供的原理圖庫編輯器可以用來創建,修改原理圖元件以及管理元件庫。這個編輯器與原理圖編輯器類似,使用同樣的圖形對象,比原理圖編輯器多了引腳擺放工具。原理圖元件可以由一個獨立的部分或者幾個同時裝入一個指定PCB 封裝的部分組成,這些封裝存儲在PCB 庫或者集成庫中。可以使用原理圖庫中的拷貝及粘貼功能在一個打開的原理圖庫中創建新的元件,也可以用編輯器中的畫圖工具。

原理圖庫
    原理圖庫作為重要的部分被包含在存儲於AltiumLibrary 文件夾中的集成庫內。要在集成庫外創建原理圖庫,打開這個集成庫,選擇“YES”釋放出源庫,接下來就可以進行編輯。要了解更多的集成庫信息,參閱集成庫指南。你也可以從一個打開的項目中的原理圖文件創建所有用到的元件的庫,使用Design»Make Project Library 命令。

創建新的原理圖庫
在我們開始創建新的元件前,先生成一個新的原理圖庫以用來存放元件。通過以下的步驟來完成建立一個新的原理圖庫。
1. 選擇File»New»Schematic Library 命令。一個新的被命名為Schlib1.SchLib 的原理圖庫被創建,一個空的圖紙在設計窗口中打開,新的元件命名為Component_1。
2. 選擇File»Save As 命令,將庫文件更名為SchematicComponents.SchLib,打開將要存儲庫的文件夾,將文件更名為以“.SchLib”為擴展名的文件然後存儲。
3. 點擊庫編輯標籤打開原理圖庫面板。
 

創建新的原理圖元件
    要在一個打開的庫中創建新的原理圖元件,你通常要選擇Tools»New Component 命令,但是因為一個新的庫都會帶有一個空的元件圖紙,我們只需簡單的將Component_1 更名然後開始創建我們的第一個元件,一個NPN 型三極體。
1. 在原理圖庫面板列表中選中Componet_1,選擇Tools»Rename Component命令。在New Component Name 對話框中輸入新的可以唯一確定元件的名字,例如:TRANSISTOR NPN。
 
2. 如果需要的話,使用Edit.Jump.Origin 命令將圖紙原點調整到設計窗口的中心。快捷鍵“J,O”。檢查屏幕左下角的狀態線以確定你定位到了原點。Altium 公司提供的元件均創建於由穿過圖紙中心的十字線標註的點旁。元件的參考點是在你擺放元件時你所抓取的點。對於一個原理圖元件來說,參考點是最靠近原點的電氣連接點(熱點),通常就是最靠近的引腳的電氣連接末端。
3. 在庫編輯器工作對話框中將捕捉柵格設為1,可視柵格設為10,選擇Tools.Document Option 命令來打開這個對話框。點擊“OK”按鈕,接受其他的默認設置。如果看不到柵格,按下Page Up 鍵可以顯示柵格。
 
4. 如例子中的NPN 三極體,我們首先要定義它的元件實體。選擇Place»Line 命令(快捷鍵 P,L)或者點擊Place Line 工具條按鈕。按下TAB 鍵,彈出“PolyLine”對話框,在框中設置線屬性然後點擊“OK”。點擊滑鼠左鍵從坐標0,-1 開始到坐標0,-19 結束畫一條垂直的線。點擊滑鼠右鍵完成這條線的擺放。現在畫坐標從0,-7 到10,0,以及從0,-13 到10,-20 的其他兩條線,使用Shift+SPACEBAR 組合鍵可以將線調整到任意角度。單擊右鍵或者按下ESC 按鈕退出擺線模式。
 
5. 箭頭是一個封閉的多邊形。選擇Place»Polygon 命令(快捷鍵P,Y)或者點擊Place Polygon 工具條按鈕。按下TAB 鍵在彈出的多邊形對話框中設置多邊形屬性然後點擊OK。在箭頭位置點擊從三角形定點開始畫三角形然後單擊右鍵結束。單擊右鍵或者按下ESC 按鈕退出擺放多邊形模式。
 
6. 保存元件(快捷鍵Ctrl+S)。

給原理圖元件添加引腳
元件引腳賦予元件電氣屬性並且定義元件連接點。引腳同樣擁有圖形屬性。在原理圖編輯器中為元件擺放引腳:
1. 選擇Place»Pins 命令(快捷鍵P,P)或者點擊Place Pins 工具條按鈕。引腳出現在指針上且隨指針移動,與指針相連一端是與元件實體相接的非電氣結束端。
2. 擺放過程中,放置引腳前,按下TAB 鍵編輯引腳屬性。引腳屬性對話框彈出。如果你在放置引腳前定義引腳屬性,你定義的設置將會成為默認值,引腳編號以及那些以數字方式命名的引腳名在你放置下一個引腳時會自動加一。
 
3. 在引腳屬性對話框中,在顯示名字欄輸入引腳的名字,在標識符欄輸入唯一可以確定的引腳編號。如果你希望當你在原理圖圖紙上放置元件時引腳名及編號可見,點開Visible 複選框。
4. 在電氣類型下拉框中選擇選項來設置引腳電氣連接的電氣類型。當編譯項目進行電氣規則檢查時以及分析一個原理圖文件檢查器電氣配線錯誤時會用到這個引腳電氣類型。在這個元件例子中,所有的引腳都是“Passive”電氣類型。
5. 在長度欄中設置引腳的長度,單位是“百分之幾英寸”。這個元件中所有的引腳長度均設為20,然後點擊“OK”。
6. 當引腳出現在指針上時,按下空格鍵可以以90 度為增量旋轉調整引腳。記住,引腳上只有一端是電氣連接點,你必須將這一端放置在元件實體外。非電氣端有一個引腳名字靠著它。
7. 繼續放置這個元件所需要的其他引腳,並確認引腳名,編號,符號以及電氣類型正確。
 
8. 現在已經完成了元件的繪製,然後選擇File»Save 命令存儲(快捷鍵Ctrl+S)。

添加引腳註意事項

  •  要在放置引腳後設置引腳屬性,只需雙擊這個引腳或者在原理圖庫面板里的引腳列表中雙擊引腳。
  •  在字母后加反斜杠()可以定義讓引腳中名字的字母上面加線,例如:MCLR/VPP 會顯示為
  •  如果你希望隱藏器件中的電源和地引腳,點開“Hide”複選框。當這些引腳被隱藏時,這些引腳會被自動的連接到圖中被定義的電源和地。例如:當元件擺放到圖中時,VCC 腳會被連接到VCC 網路。
  •  要查看隱藏的引腳,選擇View»Show Hidden Pins 命令(快捷鍵V,H)。所有被隱藏的引腳會在設計窗口中顯示。引腳的顯示名字和默認標識符也會顯示。
  •  可以在元件引腳編輯對話框中編輯引腳屬性,而不用通過每一個引腳相應的引腳屬性對話框。點擊元件屬性對話框中的“Edit Pins”按鈕彈出元件引腳編輯對話框。
     
  •  對於一個多部分的元件,被選擇部件相應的引腳會在元件引腳編輯對話框中以白色為背景高亮顯示。其他部件相應的引腳會變灰。然而,你仍然可以編輯這些沒有選中的引腳。選擇一個引腳然後點擊Edit 按鈕彈出這個引腳的屬性對話框。




[admin via 研發互助社區 ] PROTEL DXP創建原理圖器件已經有2685次圍觀

http://cocdig.com/docs/show-post-44266.html