Protel DXP 實例指導教程

admin @ 2014-03-26 , reply:0

  Protel DXP是一款Windows NT/XP的全32位電子設計系統。Protel DXP提供一套完全集成的設計,這些工具讓你很容易地將你的設計從概念形成最終的板設計。

  所有的Protel DXP工具需要在一個單一應用環境--設計探索者(the Design Explorer)中運行。啟動Protel DXP,設計探索者打開,將你所有的設計工具放在你的手指尖。你將從一個單一的、一致的、個性化的用戶環境受益。

  這個教程的設計是為了為你提供一個怎樣建立一張原理圖、從PCB更新設計信息以及產生生產輸出文件的預覽。

  設計探索者是你與你的設計和設計工具的界面。要啟動Protel並打開設計探索者,從Windows開始菜單選擇 Programs > Altium > Protel DXP 。 當你打開Protel DXP后,將顯示最常用的初始任務以便方便選擇(如圖)。
  
 
  在你建立了你的設計文件夾后,你就能在編輯器之間轉換,例如,原理圖編輯器和PCB編輯器。設計探索者將根據你當前所工作的編輯器來改變工具欄和菜單。一些工作區面板的名字最初也會顯示在工作區右下角。在這些名字上點擊將會彈出面板,這些面板可以通過移動、固定或隱藏來適應你的工作環境。

設計文件怎樣保存

  Protel DXP將所有的設計文件和輸出文件都作為個體文件保存在你的硬碟。你可以使用Windows Explorer來查找。項目文件可以的建立可以包含設計文件的連接,這樣使得設計驗證和同步成為可能。

創建一個新項目

  在Protel DXP中,一個項目包括所有文件夾的連接和與設計有關的設置。一個項目文件,例如 xxx.PrjPCB ,是一個ASCII文本文件,用於列出在項目里有哪些文件以及有關輸出的配置,例如列印和CAM。那些與項目沒有關聯的文件稱作 “ 自由文件( free documents ) ” 。與原理圖紙和目標輸出的連接,例如PCB、FPGA、VHDL或庫封裝,將添加到項目中。一旦項目被編輯,設計驗證、同步和對比就會產生。例如,當項目被編輯后,項目中的原始原理圖或PCB的任何改變都會被更新。

  建立一個新項目的步驟對各種類型的項目都是相同的。我們將以PCB項目為例。首先我們要創建一個項目文件,然後創建一個空的原理圖圖紙以添加到新的空項目中。在這個教程的最後我們將創建一個空白PCB並將它同樣添加到項目中。

為開始教程,創建一個新的PCB項目:

1、在設計窗口的 Pick a Task 區中點擊 Create a new Board Level Design Project 。
    
 
  另外,你以可以在 Files 面板 中的 New 區點擊 Blank Project (PCB) 。 如果這個面板未顯示,選擇 File > New , 或點擊設計管理面板底部的 Files 標籤。

2、 Projects 面板出現。新的項目文件, PCB Project1.PrjPCB , 與 “ no documents added” 文件夾一起列出。
  
 
3、通過選擇 File > Save Project As 來將新項目重命名(擴展名為* .PrjPCB )。指定你要把這個項目保存在你的硬碟上的位置,在文件名欄里鍵入文件名 Multivibrator.PrjPCB 並點擊 Save 。

下面,我們將創建一個原理圖並添加到空項目文件。這個原理圖是一個多諧振蕩器電路。

創建一個新的原理圖圖紙

創建一個新的原理圖圖紙按照以下步驟來完成:

1、在 Files 面板的 New 單元選擇 File > New 並點擊 Schematic Sheet 。 一個名為 Sheet1.SchDoc 的原理圖圖紙出現在設計窗口中,並且原理圖文件夾也自動地添加(連接)到項目。這個原理圖圖紙現在列表在 Projects 標籤中的緊挨著項目名下的 Schematic Sheets 文件夾下。
   
 
2、通過選擇 File > Save As 來將新原理圖文件重命名(擴展名為* .SchDoc )。指定你要把這個原理圖保存在你的硬碟中的位置,在文件名欄鍵入 Multivibrator.SchDoc ,並點擊 Save 。

3 、 當空白原理圖紙打開后,你將注意到工作區發生了變化。主工具欄增加了一組新的按鈕,新的工具欄出現,並且菜單欄增加了新的菜單項。現在你就在原理圖編輯器中了。

  你可以自定義工作區的許多模樣。例如,你可以重新放置浮動的工具欄。單擊並拖動工具欄的標題區,然後移動滑鼠重新定位工具欄。改變工具欄,可以將其移動到主窗口區的左邊、右邊、上邊或下邊。

現在我們可以在設計開始之前將我們的空白原理圖添加到項目中了。

將原理圖圖紙添加到項目中

  如果你想添加到一個項目文件中的原理圖圖紙已經作為自由文件夾被打開,那麼在 Projects 面板的 Free Documents 單元 schematic document 文件夾上右擊,並選擇 Add to Project 。 現在這個原理圖圖紙就列表在 Projects 標籤中的緊挨著項目名下的 Schematic Sheets 文件夾下,並連接到項目文件。

設置原理圖選項

在你開始繪製電路圖之前首先要做的是設置正確的文件夾選項。完成以下步驟:

1、從菜單選擇 Design > Options , 文件夾選項對話框打開。作為本教程,在此我們唯一需要修改的是將圖紙大小( sheet size ) 設置為標準A4格式。在 Sheet Options 標籤,找到 Standard Styles 欄。點擊輸入框旁的箭頭將看見一個圖紙樣式的列表。

2、使用滾動欄來向上滾動到 A4 樣式並點擊選擇。

3、點擊 OK 按鈕關閉對話框,更新圖紙大小。

4、為將文件再全部顯示在可視區,選擇 View > Fit Document 。

  在Protel DXP中,你可以通過只按菜單熱鍵(在菜單名中帶下劃線的字母)來激活任何菜單。以後任何菜單項也將有你可以用來激活該項的熱鍵。例如,對於選擇 View > Fit Document 菜單項的熱鍵就是在按了V鍵后按D鍵。許多子菜單,諸如 Edit > DeSelect 菜單,是可以直接調用的。要激活 Edit > DeSelect > All 菜單項,你只需要按X鍵(用於直接調用 DeSelect 菜單)及A鍵。

下面我們將進行一般的原理圖參數設置:

1、從菜單選擇 Tools > Preferences ( 熱鍵T,P)打開原理圖參數對話框。這個對話框允許你設置全部參數,這些將應用到你將繼續工作的所有原理圖圖紙。

2、點擊 Default Primitives 標籤以使其為當前,勾選 Permanent 。 點擊 OK 按鈕關閉對話框。

3、在你開始繪製原理圖之前,保存這個原理圖圖紙,因此選擇 File > Save ( 熱鍵F,S)。

繪製原理圖

  你現在準備開始繪製原理圖了。在這個教程中,我們將使用如下圖 ( Figure 1 ) 所示的電路。這個電路用了兩個2N3904晶體管來完成自激多諧振蕩器。 
  
 
定位元件和載入元件庫
  管理數以千計的原理圖符號也包括在Protel DXP中,原理圖編輯器提供強大的庫搜索功能。儘管我們需要的元件已經在默認的安裝庫中,但對於知道怎樣通過庫搜索來找到元件還是很有用的。通過以下步驟的操作來定位並添加本教程電路所要用到的庫。

首先我們要查找晶體管,兩個均為2N3904。
  
 
1、點擊 Libraries 標籤顯示庫工作區面板。

2、在庫面板中按下 Search 按鈕,或選擇 Tools > Find Component 。 這將打開查找庫對話框。

3、確認 Scope 被設置為 Libraries on Path , 並且 Path 區含有指向你的庫的正確路徑。如果你接受安裝過程中的默認目錄,路徑中會顯示 C:\Program Files\Altium\Library\ 。確認 Include Subdirectories 未被選擇 (未被勾選)。

4、我們想查找所有與3904有關的,所以在 Search Criteria 單元的 Name 文本框內鍵入 *3904* 。

5、點擊 Search 按鈕開始查找。當查找進行時 Results 標籤將顯示。如果你輸入的規則正確,一個庫將被找到並顯示在查找庫對話框。

6、點擊 Miscellaneous Devices.IntLib 庫以選擇它。

7、點擊 Install Library 按鈕使這個庫在你的原理圖中可用。

8、關閉 Search Libraries 對話框。

  添加的庫將顯示在庫面板的頂總。如果你點擊上面列表中的庫名,庫中的元件會在下面列表。面板中的元件過濾器可以用來在一個庫內快速定位一個元件。



[admin via 研發互助社區 ] Protel DXP 實例指導教程已經有1836次圍觀

http://cocdig.com/docs/show-post-44434.html